BLOG BUDAK BUNGO

Pages

Connect With Us

Instructions

Recomended

blogbudakbungo. Powered by Blogger.

Labels

Las series más vistas

Categories

Followers

Our Partners

Archive

Showing posts with label mikrotik. Show all posts
Showing posts with label mikrotik. Show all posts

Perintah Untuk Menghubungkan External Proxy ke Mikrotik


Dengan adanya server proxy didalam suatu koneksi atau warnet anda sangat dapat membantu dalam mengoptimalkan koneksi anda sehingga proxy dapat dikatakan sangat membantu jaringan anda seperti untuk update pacth games online, youtube streaming dan download file-file extention. Sehinggga dengan adanya proxy maka semua yang tertera diatas itu dapat dengan lancar kita terima apabila file-file tersebut sudah pernah anda download atau buka, jadi jaringan ada dapat menjadi normal.

Langsung saja ke permasalahan, yaitu untuk menghubungkan external proxy ke mikrotik anda sebagai berikut.
Pertama anda dapat membuat nama interface di salah satu ethernet di mikrotik, contoh anda membuat ethernet 3 dengan perintah sebagai berikut

/interface set 2 name=proxy

Kemudian adan dapat membuat ip address pada salah satu ethernet yang berada di mikrotik ke proxy yakni ip address tersebut sebagai gateway proxy, contohnya kita membuat di ethernet 3 pada mikrotik dengan perintah sebagai berikut

/ip address add address=192.168.200.2 netmask=255.255.255.0 interface=proxy

Kemudian selanjutnya  anda dapat membuan nat untuk proxy tersebut dengan perintah

/ip firewall nat add chain=srcnat out-interface=public action=masquerade commant=”MASQUERADE PROXY” src-address=192.168.200.0/24


Lalu anda dapat membuat transparent proxy di nat tersebut dengan perintah

/ip firewall nat add chain=dstnat src-address=!192.168.200.0/24 protocol=tcp dst-port=80 in-interface=local action=dst-nat to-addresses=192.168.200.2 to-ports=3128 commant=”TRANSPARENT PROXY”

dan gambar nya dapat anda lihat  dibawah ini 





 
Kemudian anda dapat membuat perintah mangle untuk hit proxy nya dengan perintah

/ip firewall mangle add action=mark-packet chain=postrouting comment="SQUID PROXY HIT" disabled=no dscp=12 new-packet-mark="http://www.interfacewirelessbridge.blogspot.com (PROXY HIT)" passthrough=no

Kemudian anda dapat membuat queue type untuk proxy dengan perintah

/queue type add kind=pcq name=”PROXY DOWN” pcq-classifier=dst-address

Kemudian anda dapat membuat queue tree untuk hit proxy dengan perintah

/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=5M max-limit=50M name="PROXY HIT" packet-mark="http://www.interfacewirelessbridge.blogspot.com (PROXY HIT)" parent=local priority=1 queue="PROXY DOWN"

Cara Setting Mikrotik RB Indoor Seperti RB750,RB450,RB1100,RB1000 Di Set Bridge dan Setting Pengaturan Bandwidthnya


Biasanya saya postingkan setting RB Indoor seperti RB750,RB450,RB1100,RB1000 settingan nya routing,sekarang kita set Bridge (sebagai penghubung ke Modem) saja,misalnya ip modem 192.168.1.1 dan client tetap dalam satu network yaitu 192.168.1.2 sampai 192.168.1.254 dengan bandwidth tetap bisa di atur di mikrotik indoor tersebut.ok mari kita mulai:
Topologi jaringan saya:
IP Modem = 192.168.1.1
Netmask=255.255.255.0
  • Pertama hubungkan LAN dari Mikrotik Ethernet nomor 2  ke PC dan masukkan ip di PC=
    • Ip Address=192.168.1.2 (sesuaikan dengan network anda)
    • Netmask=255.255.255.0
    • Gateway=192.168.1.1 (sesuaikan dengan network anda)
    • DNS=192.168.1.1 (sesuaikan dengan network anda)
Seperti gambar di bawah ini:
  • Selanjutnya remote Mikrotik anda dengan winbox,download winbox ((DISINI))
Seperti gambar di bawah ini:
  • Setelah masuk ke halaman winbox,pastikan winbox bersih dari settingan lama dengan mereset mikrotik tersebut,di halaman utama winbox klik “New Terminal” kemudian ketik system reset dan tekan ENTER di keyboard dan tekan huruf Y seperti gambar di bawah ini:
  • Tunggu 2 menit Mikrotik mereset system,dan kembali buka remote mikrotik dengan winbox, di halaman utama winbox klik “Remove Configuration” seperti gambar di bawah ini:
  • Selanjutnya di halaman utama winbox klik “Bridge” dan klik + dan klik “OK” seperti gambar di bawah ini:
  • Selanjutnya klik bagian TAB yaitu “Port” dan + di bagian interface nya pilih “ether1 dan di bagian Bridge nya pilih “bridge1” dan klik “OK” seperti gambar di bawah ini:
  • Klik bagian TAB yaitu “Port” lagi dan + di bagian interface nya pilih “ether2” dan di bagian Bridge nya pilih “bridge1” dan klik “OK” seperti gambar di bawah ini:
  • Selanjutnya kembali ke TAB “Bridge”  dan klik “Setting” dan centang “Use Ip Firewall” dan klik “OK” seperti gambar di bawah ini:
  • Selanjutnya sambungkan LAN=
    • Ethernet1 Mikrotik Ke Modem
    • Ethernet2 Mikrotik Ke HUB
    • PC Ke HUB
Seperti gambar di bawah ini:
  • Selanjtunya test  ping 192.168.1.1 –t dari cmd pc,dan test browsing , seperti gambar di bawah ini:
  • PC telah terkoneksi ke internet melalui Mikrotik yang di Bridge,sekarang kita buat pengaturan bandwidthnya,untuk pengaturan bandwidth saya gunakan Queue Tree membagi otomatis rata bandwidth setiap client nya.
  • Pertama kita buat Firewall filter drop virus dan anti netcut,di halaman utama winbox pilih “New Terminal” kemudian Copy scripts di bawah dan pastekan di “New Terminal” winbox...
/ip firewall filter
add action=accept chain=input disabled=no dst-port=8291 protocol=tcp
add action=drop chain=forward connection-state=invalid disabled=no
add action=drop chain=virus disabled=no dst-port=135-139 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1433-1434 protocol=tcp
add action=drop chain=virus disabled=no dst-port=445 protocol=tcp
add action=drop chain=virus disabled=no dst-port=445 protocol=udp
add action=drop chain=virus disabled=no dst-port=593 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1024-1030 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1080 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1214 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1363 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1364 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1368 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1373 protocol=tcp
add action=drop chain=virus disabled=no dst-port=1377 protocol=tcp
add action=drop chain=virus disabled=no dst-port=2745 protocol=tcp
add action=drop chain=virus disabled=no dst-port=2283 protocol=tcp
add action=drop chain=virus disabled=no dst-port=2535 protocol=tcp
add action=drop chain=virus disabled=no dst-port=2745 protocol=tcp
add action=drop chain=virus disabled=no dst-port=3127 protocol=tcp
add action=drop chain=virus disabled=no dst-port=3410 protocol=tcp
add action=drop chain=virus disabled=no dst-port=4444 protocol=tcp
add action=drop chain=virus disabled=no dst-port=4444 protocol=udp
add action=drop chain=virus disabled=no dst-port=5554 protocol=tcp
add action=drop chain=virus disabled=no dst-port=8866 protocol=tcp
add action=drop chain=virus disabled=no dst-port=9898 protocol=tcp
add action=drop chain=virus disabled=no dst-port=10080 protocol=tcp
add action=drop chain=virus disabled=no dst-port=12345 protocol=tcp
add action=drop chain=virus disabled=no dst-port=17300 protocol=tcp
add action=drop chain=virus disabled=no dst-port=27374 protocol=tcp
add action=drop chain=virus disabled=no dst-port=65506 protocol=tcp
add action=jump chain=forward disabled=no jump-target=virus
add action=drop chain=input connection-state=invalid disabled=no
add action=accept chain=input disabled=no protocol=udp
add action=accept chain=input disabled=no limit=50/5s,2 protocol=icmp
add action=drop chain=input disabled=no protocol=icmp
add action=accept chain=input disabled=no dst-port=21 protocol=tcp
add action=accept chain=input disabled=no dst-port=22 protocol=tcp
add action=accept chain=input disabled=no dst-port=23 protocol=tcp
add action=accept chain=input disabled=no dst-port=80 protocol=tcp
add action=accept chain=input disabled=no dst-port=8291 protocol=tcp
add action=accept chain=input disabled=no dst-port=1723 protocol=tcp
add action=accept chain=input disabled=no dst-port=23 protocol=tcp
add action=accept chain=input disabled=no dst-port=80 protocol=tcp
add action=accept chain=input disabled=no dst-port=1723 protocol=tcp
add action=add-src-to-address-list address-list=DDOS address-list-timeout=15s
\
chain=input disabled=no dst-port=1337 protocol=tcp
add action=add-src-to-address-list address-list=DDOS address-list-timeout=15m
\
chain=input disabled=no dst-port=7331 protocol=tcp
src-address-list=knock
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="Port scanners
to list " \
disabled=no protocol=tcp psd=21,3s,3,1
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="SYN/FIN scan"
disabled=no \
protocol=tcp tcp-flags=fin,syn
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="SYN/RST scan"
disabled=no \
protocol=tcp tcp-flags=syn,rst
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="FIN/PSH/URG
scan" disabled=\
no protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="ALL/ALL scan"
disabled=no \
protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="NMAP NULL
scan" disabled=no \
protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp
src-address=61.213.183.1-61.213.183.254
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp
src-address=67.195.134.1-67.195.134.254
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp
src-address=68.142.233.1-68.142.233.254
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp
src-address=68.180.217.1-68.180.217.254
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp
src-address=203.84.204.1-203.84.204.254
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp src-address=69.63.176.1-69.63.176.254
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp src-address=69.63.181.1-69.63.181.254
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp
src-address=63.245.209.1-63.245.209.254
add action=accept chain=input comment="ANTI NETCUT" disabled=no dst-port=\
0-65535 protocol=tcp
src-address=63.245.213.1-63.245.213.254
Seperti gambar di bawah ini:
  • Hasilnya bisa di lihat di halaman utama winbox pilih “Ip” kemudian “Firewall” kemudian TAB “Filter Rules”,seperti gambar di bawah ini:
  • Selanjutnya kita buat setting mangle untuk queue tree download dan upload,di halaman utama winbox pilih “New Terminal” dan Copy Scripts di bawah dan pastekan di “New Terminal” winbox..
Perlu di perhatikan sebelum copy paste,scripts di bawah yang saya kasih spidol merah di sesuaikan network tersebut dengan network anda,setelah di edit dengan network anda baru di pastekan di “New Terminal” Winbox....
/ip firewall mangle add action=mark-connection \
chain=forward comment="SEMUA KONEKSI" disabled=no \
new-connection-mark="SEMUA KONEKSI" passthrough=yes
/ip firewall mangle add action=mark-packet \
chain=forward comment="PAKET DOWNLOAD" \
connection-mark="SEMUA KONEKSI" disabled=no \
dst-address=192.168.1.0/24 \
new-packet-mark="PAKET DOWNLOAD" \
passthrough=no
/ip firewall mangle add action=mark-packet \
chain=forward comment="PAKET UPLOAD" \
connection-mark="SEMUA KONEKSI" disabled=no \
new-packet-mark="PAKET UPLOAD" passthrough=no \
src-address=192.168.1.0/24
Seperti gambar di bawah ini:
  • Bisa di lihat di halaman utama winbox pilih “Ip” kemudian “Firewall” kemudian TAB “Mangle”,seperti gambar di bawah ini:
  • Selanjutnya Queue Type,Copy Paste scripts di bawah di “New Terminal” Winbox:
/queue type add kind=pcq name=DOWNLOAD \
pcq-classifier=dst-address,dst-port
/queue type add kind=pcq name=UPLOAD \
pcq-classifier=src-address,src-port
Seperti gambar di bawah ini:
  • Selanjutnya kita set Queue tree untuk membagi otomatis rata bandwidth setiap client nya, Copy Paste scripts di bawah di “New Terminal” Winbox:
/queue tree add name=DOWNLOAD \
packet-mark="PAKET DOWNLOAD" \
parent=global-out \
priority=1 queue=DOWNLOAD
/queue tree add name=UPLOAD \
packet-mark="PAKET UPLOAD" \
parent=ether1 \
priority=1 queue=UPLOAD
Seperti gambar di bawah ini:
  • Bisa di lihat di halaman utama winbox pilih “Queues” kemudian TAB “Queue Tree”,seperti gambar di bawah ini:
  • Selanjutnya test browsing sambil melihat traffic di Queue Tree ..apakah sudah berjalan Avg.Rate nya? ..jika sudah berjalan maka setting sudah benar seperti gambar di bawah ini:
Selesai dan selamat mencoba...
Proudly powered by : Blogger
Copyright © 2013. Blog Budak Bungo - All Rights Reserved
Blog By : Vhen Part II
Template by blogbudakbungo.blogspot.com | Publish :budakbungo